Sample rate for recording audio?

The place for Cakewalk beginners to discuss everything Cakewalk.

Sample rate for recording audio?

Postby Guest » Tue Dec 16, 2003 4:11 am

I've been tearing my hair out for a couple of days now. Here's the problem:

I'm trying to synch a sound recording made on minidisc to a video file of a stage show. The sound recording on the minidisc is 58 minutes and the video file is 58 minutes. No problem. However, when I record the minidisc (analogue) into cakewalk the sound file gets streched to 64 minutes.

There are two possible reasons for this:

1. It could be latency and somehow the clock in my computer is running 10% too slow, but there is no other software running apart from Calkwalk.

2. The soundcard is sampling the minidisc at 48kHz and calkwalk is playing it back at 44.1kHz. This seems more likely to me, since this would account for the percentage difference in length.

I know that projects in Calkwalk are automatically set to 44.1kHz. it is possible that the soundcard is over-riding any recording settings from calkwalk.

I have a couple of questions. How do I set the recording samping rate for my soundcard? How do I set recording sampling rate for Calkwalk?

System:

Windows 98
Pentium 3 800
Audiophile 2496 sound card
Soundblaster live (for synth only)
Calkwalk home studio

Recording done through the Audiophile card.

By the way, I've solved this by dubbing directly onto the DV tape in the video camera, but I'm eager to figure this one out.
Guest
 

Re: Sample rate for recording audio?

by Sponsor

Forum Sponsor
 

Postby GretscGuy » Tue Dec 16, 2003 1:05 pm

Several things to check:
1- Make sure that Home STudio is set for 44.1k

2- Is the sound correct? it shouldn't sound lower (in pitch) than whats on the md?

3- Are you using fsk or smpte to your video or is the video on your pc?

4- Is your minidisk recorded at 44.1 or 48k?

The fact is, if the sample rate was off, you would hear it as pitch decresing or as distortion.

I can tell you right now that if you're watching a video and recording audio on a slow machine (800Mhz) you're probably going to have some sync problems. What os the goal of this project? (dvd, cd-r, vcr, web, etc...?)

You probably would be better off working with a tool like Vegas (Sonic Foundry) or Premier (Adobe) for something like this.

You may want to look into writing an .xml script and putting some markers in your video, you could do this in straight .xml or use .sml, etc...

I didn't even know you could attempt a project like this in Home Studio. I know ProAudio 8 and up gives you the option of working with a video track, you may want to check ebay for a license transfer and upgrade.
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA

Postby JimHill » Wed Dec 17, 2003 8:40 am

Hi, i was the guest, I've registered now.

Yes you can import video into home studio and all the video editing takes place on another computer. That's not really the issue. The computer above is only used for recording.

To answer some of your helpful points,

Home studio is set for 44.1, but I have no idea whether that sets the recording sample rate. 44.1 seem to be the operational sample rate when running.

The sound does sound lower, which is why I think I have a sample rate mix up.

The video is irrelevant. In effect the video and the minidisc are synched. In effect I can play the minidisk and watch the video and they are in synch.

Sample rate on the mindisc is irrelevant since the output that I record is analogue.

My suspicion is that my sound card is sampling the audio at 48. Can I set an individual track on Home Studio to a different rate? If I set that track to 48 then the length to come back to normal?
JimHill
 
Posts: 2
Joined: Tue Dec 16, 2003 3:58 am

Postby Guest » Wed Dec 17, 2003 8:58 pm

Jim,
If your source material was recorded in 44.1/16 on your MD, and is exactley 58 minutes long I can tell you this:

The raw file should be 580 megs in size when you save the stereo .wav file from your MD. If you are seeing a size closer to 696, you are at 48/16.

Try saving the lower pitched wav file onto your desktop and check the file size, this will tell you for sure. I am guessing this is the problem based on your system and my mathematical calcs. The file sizes may be a tad larger/smaller if the time is +/- 58 minutes respectfully, but this should give you a general idea.

I don't own the program you are using, but I would gess that there is probably an 0ptions/audio setting somewhere. I do know that program works in 96/24, so hearing it correctley will not be a problem.

You may want to look into your card's settings if you are planning to make an audio cd of the wav, downsampling is a pain and seeing as how (I assume) your already at 44.1/16 now, there is really no point in upsampling only to downsample later.

Good Luck!
Guest
 

Postby GretscGuy » Wed Dec 17, 2003 8:59 pm

Jim,
If your source material was recorded in 44.1/16 on your MD, and is exactley 58 minutes long I can tell you this:

The raw file should be 580 megs in size when you save the stereo .wav file from your MD. If you are seeing a size closer to 696, you are at 48/16.

Try saving the lower pitched wav file onto your desktop and check the file size, this will tell you for sure. I am guessing this is the problem based on your system and my mathematical calcs. The file sizes may be a tad larger/smaller if the time is +/- 58 minutes respectfully, but this should give you a general idea.

I don't own the program you are using, but I would gess that there is probably an 0ptions/audio setting somewhere. I do know that program works in 96/24, so hearing it correctley will not be a problem.

You may want to look into your card's settings if you are planning to make an audio cd of the wav, downsampling is a pain and seeing as how (I assume) your already at 44.1/16 now, there is really no point in upsampling only to downsample later.

Good Luck!
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA

Postby JimHill » Thu Dec 18, 2003 4:56 am

Thanks Gretsguy,

I have to believe that the sample rate is coming from the soundcard settings, since the minidisk is just sending an analogue signal to the card. I've tried finding something in the audiofile control panel to set the recording rate but I can't. I also downloaded the new driver from M-Audio, but I can't get it to install. Anyone else had the same problem?

In the end I've done a stretch in Adobe Audition which seems to work. Synching is not completely perfect, but when the thing is reduced to appear on VHS, VCD and DVD I think it will be ok. Still I'd like to know why the recording is not matching up. In terms of file size, the audio from the video file is almost exactly the same ratio smaller than the MD recording as 44.1 is to 48, so I think that is the problem. I just can't seem to figure out how to control the sampling rate of the recording.

Is it in cakewalk or is it in the audio card driver? I just can't find the switch. :cry:
JimHill
 
Posts: 2
Joined: Tue Dec 16, 2003 3:58 am

Postby GretscGuy » Thu Dec 18, 2003 1:35 pm

Jim,
I don't have the particular program that you are using, however I do knowe it handles multiple sample rates.

Is it possible your soundcard's sample rate needs to be adjusted?
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA

Just play it back?

Postby dryan08 » Wed Jan 21, 2004 2:45 am

Are you actually playing back the sound into Home Studio, or are you attempting to import the raw .wav file you've already recorded?

If you just play the audio back into the file that already contains the video, you will (obviously) play back the same 58 minutes that the video takes. After that, you should be able to slide the audio track to sync with the video.

If you have imported the video, rather than played it back, that could perhaps cause the same sampling rate problem as the audio. By playing both the audio and video into a new file, they should both end up being resampled at whatever rate home studio wants to use.
dryan08
 

Postby GretscGuy » Thu Jan 22, 2004 10:54 pm

you should be able to slide the audio track to sync with the video.


Not neccesarily, if the sample rate is off the length of the audio track will have changed.
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA



Similar topics


Return to Beginners

Who is online

Users browsing this forum: No registered users and 1 guest


Music Engravers and Music Copyists
   Finale - Sibelius - Cakewalk - Archives - Cakewalk Books - Contact


Copyright © 1994 - 2019 by C.M. Press, LLC