CWPA9 - audio tracks screws up tempo

The place for general discussion of Cakewalk Pro Audio.

CWPA9 - audio tracks screws up tempo

Postby befuddled » Fri Mar 04, 2005 7:35 pm

I've been working peacefully with CWPA9 for years, but last week a new problem cropped up that I haven't been able to figure out.

A new project I've been working on contains a few tracks of MIDI. When I went to record my first audio track, I noticed the click track speeding up to about twice the proper speed. the project should be at 110 bpm, but when I try to record audio, it jumps to somewhere around 175 bpm, if I had to guess.. (the tempo view still shows the proper tempos)

Playback with any audio track anywhere in the project gets the fast speed. If I undo the audio track, it goes back to normal tempo. If I paste or import in a wave file, it speeds up.

My old projects (with audio) still work. No new projects work right.

Any ideas? My only theory is that my 1 year-old, while banging away at my keyboard, hit some bizare combination of keys that causes the program to barf. :shock:
befuddled
 

Re: CWPA9 - audio tracks screws up tempo

by Sponsor

Forum Sponsor
 

Postby andychap » Fri Mar 04, 2005 7:45 pm

Make sure when you are recording you sync up to the midi tracks. You get a choice of syncing to midi, internal, external etc. Mess around with those settings.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby befuddled » Fri Mar 04, 2005 7:52 pm

oh, if only it were that simple...I've tried all of those settings. The sync setting I've always used, and left it on for now, is "Audio".

-steve
befuddled
 

Postby andychap » Fri Mar 04, 2005 8:17 pm

If you are recording from a keyboard and you use this keyboard as a midi controller as well, make sure it is not still transmitting midi while you are trying to record audio. It might be sending a signal to adjust the tempo when you press a certain key. Best thing would be to unplug any midi leads.

The trouble is when mixing midi with audio when recording is that they both use different clocks. One uses a clock in the software and the other uses the computer clock.

Have you tried converting your midi to audio tracks and then recording the audio. You should then be working with the same clock.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby befuddled » Fri Mar 04, 2005 8:33 pm

I have tried:

* recording audio from a midi track
* recording from an an audio source (guitar)
* pasting audio from the clip buffer
* importing a wave file

all have the same effect. I also started a new project, pasted in the midi tracks, then tried any of the above, and still get the problem.

I'll try disconnecting some of the midi connections when I get home. thanks for the suggestions.
befuddled
 

Postby andychap » Sat Mar 05, 2005 12:09 pm

Another area to look at would be the soundcard. What S/C do you have and does it have the latest drivers?

Check that your operating system is working correctly and tweaked to the optimum for audio performance. It suprising how little things like programs running in the background will have such an effect, especially in XP.

Other than that I think a big fence around the studio to keep little fingers at bay :wink: :D

I will carry on thinking about this and if I have any ideas I will post back here.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby andychap » Sat Mar 05, 2005 12:40 pm

I found this in an old FAQ, any help?

Why are my MIDI and audio tracks out of sync?

If Wave Profiler isn't able to detect the proper DMA Size and Offset settings for your sound card, the card may not be reporting accurate timing information to Cakewalk. Therefore, you may need to choose a special Cakewalk setting that relies on a different form of sync.

Solution
Choose the "Use Wave Out Position For Timing" option under Options | Audio | Advanced (Tools | Audio Options in v. 7 and 8) in Cakewalk if you have sync problems between MIDI and audio tracks. This tells Cakewalk to ignore all DMA settings.

Note: To do the same thing in Cakewalk Pro Audio 5.0, add AltTiming=1 and OldPreSync=2 to the [Wave] section of the Audmm.INI file.

Cards that need this setting

* AdB Mult!wav
* Ensoniq Vivo
* Event Gina, Darla, and Layla
* MIDIMan DMan 2044
* SoundBlaster Live! and PCI 64/128
* Turtle Beach cards
* Zefiro Acoustics ZA2
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby befuddled » Tue Mar 08, 2005 2:23 am

Soundcard is Aardvark Aark24, with the latest drivers. I have tried just about every setting there is. The main clues to consider are:

* it used to work just fine, and all the old projects still work
* all new projects have the problem
* there's a toddler involved, so likely candidates include: pulled wires, pressed buttons, keyboard hot-keys, drool in the keyboard, etc.

I've reinstalled my soundcard drivers and Cakewalk itself, all with no difference.

The next step is the hammer solution. bash my PC until either it works or I feel better.

-steve
befuddled
 

Postby befuddled » Wed Mar 09, 2005 2:38 am

Here's another clue for y'all, which leads me to believe something is corrupt in the midi tracks and it doesn't have anything to do with clocks or sync:

Picture a project with 6 midi tracks. There is also one audio track with nothing in it, but it is armed for recording. when i press PLAY, the metronome goes bip....bip....bip....bip.... at the proper tempo. when i press RECORD it goes bip.bip.bip.bip. (at approx twice the normal tempo).

all things are equal except it's PLAY vs RECORD.

I undid the audio track and saved the project as MIDI (both type 0 and 1), took the .mid files to another computer, played them and they were at the faster wrong speed.

I think something got imbedded into one of the midi tracks?!? :shock:
befuddled
 

Postby Koos From SA » Mon Mar 14, 2005 1:45 pm

Weird thing, have you maybe gone into the midi event editor to check what's happening in there ?

Cheers !
Koos From SA
 

Postby andychap » Tue Mar 15, 2005 1:35 pm

When you say you have an Aardvark with the latest drivers are they the drivers supplied before they went bust or the ones from the independant acrchive.

I think the last official drivers were not XP compatible.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK



Similar topics


Return to General Cakewalk

Who is online

Users browsing this forum: No registered users and 1 guest


Music Engravers and Music Copyists
   Finale - Sibelius - Cakewalk - Archives - Cakewalk Books - Contact


Copyright © 1994 - 2019 by C.M. Press, LLC