General midi files sound output problem in sonar 3 producer

The place for general discussion of Cakewalk Pro Audio.

General midi files sound output problem in sonar 3 producer

Postby Robertwhiteman » Thu Dec 18, 2003 8:53 pm

Hi all,

I cant seem to get any sound from midi files i load into sonar.... it would be really handy for me to do this seen as i'm studying song arrangements.

i dont use general midi for production and have never use it b4. i have a Roland GS. and the edirol canvas i got with sonar...

the volume is up on the SW Synth in the soundcards mixer. i have tried different things but nothing seems to work...

Am i correct in thinking you dont need an audio output track when working with GM sounds?

i have set option/instruments to my roland gs gm bank. and have it selected in the channel of the midi track and a patch select theres just no sound...

i tried cubase demo and could access gm sounds in that but i uninstalled that ages ago and sonar is great for me :)


If anyone has any ideas or can shead any light on this, i would greatly appreciate it.

Thanks alot,

p.s looks like a cool site i just registered
Robertwhiteman
 
Posts: 1
Joined: Thu Dec 18, 2003 8:33 pm

Re: General midi files sound output problem in sonar 3 producer

by Sponsor

Forum Sponsor
 

sorted, but latency issue now :(

Postby Guest » Fri Dec 19, 2003 1:36 am

got the issue sorted out with switching my soundcard driver tp mme, but now i have a really shitting latency... i looked at the manual and it sez:

"If you use an MME sound card driver and your project uses an audio driver bit depth of 16, you should enable WavePipeTM Acceleration in the Audio Options dialog box, in the Driver Profiles tab"

but there is no such an option in that location....... its stupid

any one know about this option, or a way to use GM sounds without boosting your latency to an unexceptable level?

cheers
Guest
 

Postby andychap » Fri Dec 19, 2003 1:26 pm

Try lowering the buffer setting in the audio options. Set them as low as you can to get lower latency without constant dropouts. It's a bit of a juggling game.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby GretscGuy » Fri Dec 19, 2003 11:17 pm

I agree with Andy. You may also want to check your Advanced tab (Options, Audio, Advanced) and untick enable read caching, enable write caching and also adjust your I/O buffer size (smaller = better performance, larger = more stable, more latency).

Also, be sure to set your soundcard's buffer size as well. The process of doing this is dependent on your particular card.
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA



Similar topics

Future of Sonar
Forum: General Cakewalk Author: terryj Replies: 5

midi - audio
Forum: Technical Issues Author: tonki Replies: 5


Return to General Cakewalk

Who is online

Users browsing this forum: No registered users and 1 guest

cron

Music Engravers and Music Copyists
   Finale - Sibelius - Cakewalk - Archives - Cakewalk Books - Contact


Copyright © 1994 - 2019 by C.M. Press, LLC