Sonar 3 producer and terratec

This forum is dedicated to Sonar discussions.
chocos

Sonar 3 producer and terratec

Post by chocos » Wed Dec 31, 2003 2:18 am

Hello, I'm using sonar 3 producer edition with 2 terratec ews88mt sound cards configured to run together (master-slave). I switched recently to win XP and I use the latest driver pack for the cards. Well, synchronization doesn't seem to be a problem but when I start to record a new audio track, sometimes while it seems to "record" (I can see the current waveform) after pressing the stop button my waveform disappears!!! In addition, when I quit sonar I get an error message "an illegal instruction in mpla pla memory".
I'm using the asio drivers for the card.
First i thought that the problem might be to the fact that I have activated the autosave (after some minutes or actions) operation, though I doubt.
Pleaseee any ideas?? :roll: :roll: :roll:

Re: Sonar 3 producer and terratec

by Sponsor

Forum Sponsor
 

andychap
Posts: 685
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Post by andychap » Wed Dec 31, 2003 10:20 am

Boy that's a hard one. The only thing I can offer is in definition.

PLA is a Programmable Logic Array and MPLA is Multiple PLA. I think the only connection this can have with your problem is the fact that these arrays are used in EPROM and Flash memory if my memory serves me correctly.

These arrays are used to order the processes your machine makes in a logical order. In this case it could be record sound/draw waveform/record sound etc. Maybe switching off the creation of the graphical waveform whilst recording could solve this problem. Trying to cope with intensive graphics and intensive audio operations at the same time might be a bit to much for your machine to handle.

It's only a guess but it might work.

chocos

Post by chocos » Fri Jan 02, 2004 2:40 am

Well, thanx a lot, though I switched back to Cakewalk pro for now in order to avoid this kind of problems. I'll give it a try when I'll have the time to do so.
Thanx again!

GretscGuy
Posts: 434
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA

Post by GretscGuy » Wed Jan 07, 2004 12:15 am

Is your drive ntfs or fat32? I have seen similar proibs with fat32 drives

chocos

Post by chocos » Thu Jan 22, 2004 11:27 pm

Well, I solved that problem (thanx God!) and I don't get an error report any more. Right now I'm trying to synchronize these two damn cards with sonar 3 producer. My test project is to record a metronome (generated from sonar) which is connected to an Alesis D4. When I playback the audio track it cannot be synchronized with the midi metronome. What is more, I record the output of the audio track into a new track, and none of them are syncrhonized. I tried changing the number of samples/buffer in the asio control panel (I use the same config I mentioned above) but in vain.

Guest

Post by Guest » Fri Jan 23, 2004 2:23 pm

What did you do to fix it

chocos

Post by chocos » Wed Feb 04, 2004 5:58 pm

Well, I tried many things in order to fix that, and I can't recall which of them did it. Some of them were to uninstall Cubase sx which was installed in order to test it and reinstall sonar. I also fixed the synchronization prob using the default config in the driver section of sonar. I turned off the asio drivers from the terratec control panel and it worked just fine. Now I turned them back on and still I have no problems. Damn machines!

Test and test and then... test again! There's not always a logical explanation what and why...

Post Reply