any tips for decreasing CPU usage?

Use this forum for all technical issues.

any tips for decreasing CPU usage?

Postby adrian » Thu Apr 15, 2004 10:54 pm

hi

am using sonar 3.1.1, and i get a lot of dropout despite only using a few real-time effects. CPU is always running at 30-60% minimum.

have 512mb ram, 2.2G pentium 4. lots of other programs, but all disabled in the task bar.

any tips??

thanks
adrian
adrian
 
Posts: 13
Joined: Tue Apr 13, 2004 4:14 am
Location: uk

Re: any tips for decreasing CPU usage?

by Sponsor

Forum Sponsor
 

Postby kentothink » Fri Apr 16, 2004 12:49 am

what are all your buffer settings in the Options-Audio menu?
kentothink
 
Posts: 57
Joined: Thu Nov 06, 2003 4:35 pm

Postby adrian replies » Fri Apr 16, 2004 10:37 am

hi

thanks for your interest.

the buffers are set at 64k. i have tried increasing this, with little effect. the soundcard software hads buffers set at 64k too.

what does the "read caching" and "write chaching" mean? these boxes are both unchecked currently.

i also have the dither box checked. am using ASIO drivers.

any thoughts??

thanks

adrian
adrian replies
 

Postby andychap » Fri Apr 16, 2004 1:16 pm

The soundcard buffer looks way too low. Try 128 then 256 and 512 until you dropouts stop. You should still get workable latency at 512.

Also check out the optimisation thread in the general section. There are some good links and tips there.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby kentothink » Fri Apr 16, 2004 4:28 pm

I have no idea what Write and Read Caching is. anyone else know?

I keep my buffers at 64 or 128 and i happen to like it a lot and i dont have dropout problems, but i also have a MOTU 828 as my clock and im using the multiprocessing engine because i have 2 processors in my comp.

if you disable the dither until mixdown, you may notice a difference in performance. supposedly, you can tell the difference when its off and thats why i tend to wait until i mix to use it. i notice the difference on transient type instruments like clean guitars and drums. they dont punch as hard without the dither for some weird reason.
kentothink
 
Posts: 57
Joined: Thu Nov 06, 2003 4:35 pm

Postby andychap » Fri Apr 16, 2004 6:49 pm

kentothink wrote:I have no idea what Write and Read Caching is. anyone else know?

I keep my buffers at 64 or 128 and i happen to like it a lot and i dont have dropout problems, but i also have a MOTU 828 as my clock and im using the multiprocessing engine because i have 2 processors in my comp.

if you disable the dither until mixdown, you may notice a difference in performance. supposedly, you can tell the difference when its off and thats why i tend to wait until i mix to use it. i notice the difference on transient type instruments like clean guitars and drums. they dont punch as hard without the dither for some weird reason.


It's recommended to leave the read and write caching unchecked.

With a system like yours it's not suprising you can use buffers that low :D

@Adrian
I think this looks like more of a standard system although still quite powerful. Based on my system which is an ancient PIII 850 with 256 mb Ram and a Waveterminal 24/96, I need to set them at 256 for low latency playing and recording at 24/44100 and then when I start to mix and apply effect I bump it up to 512.

Depending on what the soundcard is I think anywhere between 128 and 512 would probably be best. Make sure that your soundcard that you are using for recording is not used by windows for anything else. Go into the device manager and right click on your soundcard, choose properties and then expand the audio devices option. Click on your soundcard again and choose properties again and check the Do not map through this device option. It will stop windows try to click and ring etc when you are trying to record.

You must be able to change the buffer settings on the last page of the audio settings dialogue pages. The disc buffer is fine at the default setting of 64K

Another area that people don't take into acount is graphics. Make sure your graphics acceleration is set to maximum and your screen colours set the the lowest, about 16 bit. This way your graphics card will be able to handle all you visual requirements without passing the load on to the processor.

The better condition your hard drives are in the less stress there is on your processor. Make sure they are DMA enabled and the IDE channels are set at the maximum DMA setting. Always defrag the drives before a major recording session. If you have CD drives on the same IDE channel as your drives, make sure you have the auto insert switched off and there are no discs in the drive. These are all things that can suddenly cause the CPU to spike and the audio to drop out.

You can run comfortably at 30 -60% cpu usage. The trick is to make sure nothing else kicks in and causes the CPU to spike. You need a nice smooth operation.
andychap
 
Posts: 687
Joined: Wed Aug 27, 2003 7:26 pm
Location: UK

Postby Axeman » Fri Jul 16, 2004 3:26 am

Another tip to conserve CPU usage is something people tend to forget about, but it's simple. Use as few effects as possible. Try assigning an effect to an Aux Bus Send instead of to 4 seperate tracks. Tie each track into ONE effect rather than the opposite. Consolidating effects this way can make a HUGE difference on any system. One example I have used is assigning the BBE Sonic MAximizer plug in to an Aux. and setting it sort of middle of the road, or heavy, and tying in each track to the single instance of the effect. Use the Aux send volume on the TRACK to determine the level of the effect in each track. Before I built my 3.4Ghz rig I did this a LOT. I still do it with certain plug-ins that are heavy CPU users. Particularly with the Pantheon Reverb. I can run 15 instances of the BBE MAximizer, but anything more than 3 Pantheons with medium settings and Issues can pop up even on my rig. It's really a juggling act, it just takes time to learn how to juggle well. :P
Axeman
 
Posts: 37
Joined: Tue Dec 02, 2003 6:31 pm
Location: Richmond, Virginia

Postby GretscGuy » Wed Jul 28, 2004 1:34 am

Other things to consider - are you recording at 16/44.1 or a higher rate? This will eat up space quick. Do you have lots of services running?
GretscGuy
 
Posts: 442
Joined: Sat Oct 18, 2003 1:26 pm
Location: Massachusetts USA

Postby Axeman » Fri Jul 30, 2004 10:09 pm

Another thing to consider is how many processes are running in the background. What OS is it...XP or 2000, no I won't go there again (GRIN) see other threads for that arguement, but if you have more than 25 processes running there may be a lot of your issue. If yer using XP, cut off all the crap....Messenger Service, Error Reporting Service (Unless yer troubleshooting abug), Automatic Updates, etc. These are all just eating up yer headroom. Go here: http://www.blackviper.com/ for a list of 2000 and XP services...what they are and what they do. If yer not familiar with it, in order to see your currently running processes, Click Start/Run/ and type "Services.msc", or look for Services in Administration Tools in yer control panel.

Trim the fat and you should see a big difference in performance. Have fun!
Axeman
 
Posts: 37
Joined: Tue Dec 02, 2003 6:31 pm
Location: Richmond, Virginia

Postby kentothink » Sat Aug 07, 2004 12:32 am

In Sonar, i make all my tracks from stereo to mono. and i use mono plugins on tracks that dont need to be stereo. i find this saves power, but i cant justify why!
kentothink
 
Posts: 57
Joined: Thu Nov 06, 2003 4:35 pm



Similar topics


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron

Music Engravers and Music Copyists
   Finale - Sibelius - Cakewalk - Archives - Cakewalk Books - Contact


Copyright © 1994 - 2019 by C.M. Press, LLC